{
  "draft": "draft-pd-dispatch-msrp-websocket-15",
  "doc_id": "RFC7977",
  "title": "The WebSocket Protocol as a Transport for the Message Session Relay Protocol (MSRP)",
  "authors": [
    "P. Dunkley",
    "G. Llewellyn",
    "V. Pascual",
    "G. Salgueiro",
    "R. Ravindranath"
  ],
  "format": [
    "TEXT",
    "HTML"
  ],
  "page_count": "28",
  "pub_status": "PROPOSED STANDARD",
  "status": "PROPOSED STANDARD",
  "source": "IETF - NON WORKING GROUP",
  "abstract": "The WebSocket protocol enables two-way real-time communication between clients and servers in situations where direct access to TCP and UDP is not available (for example, from within JavaScript in a web browser).  This document specifies a new WebSocket subprotocol as a reliable transport mechanism between Message Session Relay Protocol (MSRP) clients and relays to enable usage of MSRP in new scenarios.  This document normatively updates RFCs 4975 and 4976.",
  "pub_date": "September 2016",
  "keywords": [
    "MSRP",
    "WebSocket"
  ],
  "obsoletes": [],
  "obsoleted_by": [],
  "updates": [
    "RFC4975",
    "RFC4976"
  ],
  "updated_by": [],
  "see_also": [],
  "doi": "10.17487/RFC7977",
  "errata_url": null
}