{
  "draft": "draft-masotta-tftpexts-windowsize-opt-13",
  "doc_id": "RFC7440",
  "title": "TFTP Windowsize Option",
  "authors": [
    "P. Masotta"
  ],
  "format": [
    "TEXT",
    "HTML"
  ],
  "page_count": "9",
  "pub_status": "PROPOSED STANDARD",
  "status": "PROPOSED STANDARD",
  "source": "IETF - NON WORKING GROUP",
  "abstract": "The \"Trivial File Transfer Protocol\" (RFC 1350) is a simple, lockstep, file transfer protocol that allows a client to get or put a file onto a remote host. One of its primary uses is in the early stages of nodes booting from a Local Area Network (LAN). TFTP has been used for this application because it is very simple to implement. The employment of a lockstep scheme limits throughput when used on a LAN.\n\n This document describes a TFTP option that allows the client and server to negotiate a window size of consecutive blocks to send as an alternative for replacing the single-block lockstep schema. The TFTP option mechanism employed is described in \"TFTP Option Extension\" (RFC 2347).",
  "pub_date": "January 2015",
  "keywords": [],
  "obsoletes": [],
  "obsoleted_by": [],
  "updates": [],
  "updated_by": [],
  "see_also": [],
  "doi": "10.17487/RFC7440",
  "errata_url": null
}