{
  "draft": "draft-ietf-httpbis-p2-semantics-26",
  "doc_id": "RFC7231",
  "title": "Hypertext Transfer Protocol (HTTP/1.1): Semantics and Content",
  "authors": [
    "R. Fielding, Ed.",
    "J. Reschke, Ed."
  ],
  "format": [
    "TEXT",
    "HTML"
  ],
  "page_count": "101",
  "pub_status": "PROPOSED STANDARD",
  "status": "PROPOSED STANDARD",
  "source": "HTTP",
  "abstract": "The Hypertext Transfer Protocol (HTTP) is a stateless \\%application- level protocol for distributed, collaborative, hypertext information systems.  This document defines the semantics of HTTP/1.1 messages, as expressed by request methods, request header fields, response status codes, and response header fields, along with the payload of messages (metadata and body content) and mechanisms for content negotiation.",
  "pub_date": "June 2014",
  "keywords": [
    "Hypertext Transfer Protocol",
    "HTTP",
    "HTTP semantics",
    "HTTP payload",
    "HTTP content",
    "HTTP method",
    "HTTP status code"
  ],
  "obsoletes": [
    "RFC2616"
  ],
  "obsoleted_by": [
    "RFC9110"
  ],
  "updates": [
    "RFC2817"
  ],
  "updated_by": [],
  "see_also": [],
  "doi": "10.17487/RFC7231",
  "errata_url": "https://www.rfc-editor.org/errata/rfc7231"
}