{
  "draft": "draft-ietf-behave-v4v6-bih-09",
  "doc_id": "RFC6535",
  "title": "Dual-Stack Hosts Using \"Bump-in-the-Host\" (BIH)",
  "authors": [
    "B. Huang",
    "H. Deng",
    "T. Savolainen"
  ],
  "format": [
    "TEXT",
    "HTML"
  ],
  "page_count": "25",
  "pub_status": "PROPOSED STANDARD",
  "status": "PROPOSED STANDARD",
  "source": "Behavior Engineering for Hindrance Avoidance",
  "abstract": "Bump-in-the-Host (BIH) is a host-based IPv4 to IPv6 protocol translation mechanism that allows a class of IPv4-only applications that work through NATs to communicate with IPv6-only peers.  The host on which applications are running may be connected to IPv6-only or dual-stack access networks.  BIH hides IPv6 and makes the IPv4-only applications think they are talking with IPv4 peers by local synthesis of IPv4 addresses.  This document obsoletes RFC 2767 and RFC 3338. [STANDARDS-TRACK]",
  "pub_date": "February 2012",
  "keywords": [
    "NAT",
    "NAT46",
    "DNS",
    "DNS46",
    "translation",
    "IPv4",
    "applications",
    "IPv6",
    "ENR"
  ],
  "obsoletes": [
    "RFC2767",
    "RFC3338"
  ],
  "obsoleted_by": [],
  "updates": [],
  "updated_by": [],
  "see_also": [],
  "doi": "10.17487/RFC6535",
  "errata_url": "https://www.rfc-editor.org/errata/rfc6535"
}