{
  "draft": "draft-ietf-dccp-serv-codes-11",
  "doc_id": "RFC5595",
  "title": "The Datagram Congestion Control Protocol (DCCP) Service Codes",
  "authors": [
    "G. Fairhurst"
  ],
  "format": [
    "TEXT",
    "HTML"
  ],
  "page_count": "19",
  "pub_status": "PROPOSED STANDARD",
  "status": "PROPOSED STANDARD",
  "source": "Datagram Congestion Control Protocol",
  "abstract": "This document describes the usage of Service Codes by the Datagram Congestion Control Protocol, RFC 4340.  It motivates the setting of a Service Code by applications.  Service Codes provide a method to identify the intended service/application to process a DCCP connection request.  This provides improved flexibility in the use and assignment of port numbers for connection multiplexing.  The use of a DCCP Service Code can also enable more explicit coordination of services with middleboxes (e.g., network address translators and firewalls).  This document updates the specification provided in RFC 4340. [STANDARDS-TRACK]",
  "pub_date": "September 2009",
  "keywords": [
    "DCCP-Request Ports"
  ],
  "obsoletes": [],
  "obsoleted_by": [],
  "updates": [
    "RFC4340"
  ],
  "updated_by": [
    "RFC6335"
  ],
  "see_also": [],
  "doi": "10.17487/RFC5595",
  "errata_url": "https://www.rfc-editor.org/errata/rfc5595"
}